jDiction Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

jDiction 2.2.0 released. http://jdiction.org/downloads

Author Topic: Language Module: wrong alias  (Read 45363 times)

Tribal6

  • Newbie
  • *
  • Posts: 4
    • View Profile
Language Module: wrong alias
« on: April 23, 2019, 10:36:00 am »

Hello
A client of us uses JDiction. Everything works fine, but the language switcher:
It does not change the language specific alias in URL
eg.

DE
https://skan.ch/de/products-view/45-produktionsisolator-fuer-fuelllinien

has in EN in the switch module still the german alias
https://skan.ch/en/products-view/45-produktionsisolator-fuer-fuelllinien

instead of
https://skan.ch/en/products-view/45-production-isolator-for-filling-lines

Does anybody else having the same behavior? What could be wrong?
J! = 3.9.5
PHP = 7.2.14
JDiction = 2.2.2

Cheers
Roger
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: Language Module: wrong alias
« Reply #1 on: April 23, 2019, 10:52:11 am »

Hi,

are these normal articles?
Did you translated the alias?
Logged

Tribal6

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Language Module: wrong alias
« Reply #2 on: April 23, 2019, 11:49:21 am »

Yess...normal articles with different alias for every language.

You can see they if you go to a product via menu:
products -> products list -> single product
Logged

Tribal6

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Language Module: wrong alias
« Reply #3 on: April 23, 2019, 04:19:06 pm »

....I can send you admin access, if is needed to solve this  :)
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: Language Module: wrong alias
« Reply #4 on: April 23, 2019, 04:33:39 pm »

yes please, I can't check today but hopefully tomorrow.
Logged

Tribal6

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Language Module: wrong alias
« Reply #5 on: April 24, 2019, 09:19:30 am »

PM sent  :D

Thanks for your time.
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: Language Module: wrong alias
« Reply #6 on: April 25, 2019, 10:40:58 pm »

Hi,

I looked at this and found out this is a missing feature :-(

I have no ETA how long it would take to add this.

sry.
Logged