jDiction Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

jDiction 2.2.0 released. http://jdiction.org/downloads

Author Topic: As soon as I publish the jdlanguage module, the site does not work anymore  (Read 5580 times)

DimitriDV

  • Newbie
  • *
  • Posts: 2
    • View Profile

Is this a common problem? What could be wrong please?
I followed the tutorial. I am using Joomla 2.5.5 Stable and PHP 5.3.16
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: As soon as I publish the jdlanguage module, the site does not work anymore
« Reply #1 on: February 01, 2013, 10:44:30 am »

iirc 2.5.5 is broken plz update to 2.5.8 and try again
Logged

DimitriDV

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: As soon as I publish the jdlanguage module, the site does not work anymore
« Reply #2 on: February 01, 2013, 11:25:21 am »

I did the update but I still receive the error after I publish the jdlanguage module (I tried several positions, no luck there)

HTTP-fout 500 (Internal Server Error)
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: As soon as I publish the jdlanguage module, the site does not work anymore
« Reply #3 on: February 01, 2013, 01:33:07 pm »

Hmm... without error message it would be a problem to help you...

maybe you could give me an account on the joomla installation per (PM)
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: As soon as I publish the jdlanguage module, the site does not work anymore
« Reply #4 on: February 02, 2013, 01:37:54 pm »

maybe you could test the latest 0.8.9.3 version.
Logged

ms_buggy

  • Newbie
  • *
  • Posts: 2
    • View Profile

Hi,

I have the exact same problem.
Joomla version 3.3 and jDiction Release Package 1.3.0.
PHP Version   5.4.26

I have tried reinstalling, nothing.
Any known components that could case this? I dont have much installed but one big (modules and plugins) is JSN power admin.


Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile

Could you please post the output of the check page? and did you activated the plugin?
Logged

marancs

  • Newbie
  • *
  • Posts: 3
    • View Profile

Hi,

I have the same problem. I am really new to Joomla, I thought when I installed jDiction, it will work perfectly.

When I visit my site, I got the following error message: 404 Article not found.
 One think when I type  http://twin-apartments.hu, it changes to http://twin-apartments.hu/hu/. I have English, Hungarian and German as content languages.

- Joomla version 3.3
- jDiction Release Package 1.3.0.
- PHP 5.4.30

jDiction check:

Test    Result :
Version
    Library Version: 1.3.0
    Joomla Version 3.3.3 is untested.
Plugin
    JDiction Plugin is enabled
    JDiction Plugin is loaded at position 0 should be 1
    Languagefilter is enabled
Database    
    jDiction Database Driver is selected
Language    
    Translations are not equal to frontend translations.
Module    
    Module is enabled

Common mistakes    
    At least one content item has the language set not to ALL.


I tried to figure it out by myself, however unfortunately found no tutorials, in depth descriptions about jDiction.
Where can I find an in depth tutorial with examples about jDiction?

Basically need help, I do not know how to continue.
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile

Did you set the language selectbox in the article?

because the checkpage says: At least one content item has the language set not to ALL.

it seams that you changed it from "ALL" to a language, thats not necessary for jdiction and could lead to this problem.

Also you didn't show the jdlanguageswitcher module on your site.

Multilingual content is always easy in joomla.
Logged

marancs

  • Newbie
  • *
  • Posts: 3
    • View Profile

Thanks for the quick response.

The jdlanguageswitcher module is set to position 7 and it is published.
Changed a content language to Hungarian.

After the modification, I still get the error message.

Please could you help me, what am I missing?
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile

Could you send me a superuser account and password per PM?
Logged

marancs

  • Newbie
  • *
  • Posts: 3
    • View Profile

Thanks, I sent a pm.
Logged

ms_buggy

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: As soon as I publish the jdlanguage module, the site does not work anymore
« Reply #12 on: September 01, 2014, 12:33:04 pm »

Good that you mentioned the plugins, I had activated only the search plugin. Goddam1t. Everything works like a charm.
Thank you and sorry for the problem!

« Last Edit: September 01, 2014, 12:36:22 pm by ms_buggy »
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: As soon as I publish the jdlanguage module, the site does not work anymore
« Reply #13 on: September 01, 2014, 01:00:03 pm »

Good^^
Logged