jDiction Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

jDiction 2.2.0 released. http://jdiction.org/downloads

Author Topic: ARTICLE NOT FOUND  (Read 6288 times)

pindrix

  • Newbie
  • *
  • Posts: 4
    • View Profile
ARTICLE NOT FOUND
« on: March 19, 2013, 01:56:54 pm »

Hello

I do the instalation exact as in documentation. But when I make a translation of  index article ,and i press the link in the jdlanguage module. Everytime I get the error  >  article not found  . PLs help .
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #1 on: March 19, 2013, 02:03:48 pm »

could you please paste the output of the check method in jdiction administrator?
Logged

pindrix

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #2 on: March 19, 2013, 03:42:09 pm »

This ?

Test   Result
 
Version :
Library Version: 0.9
Joomla Version 2.5.9 is ok.

Plugin    :
JDiction Plugin is enabled
JDiction Plugin is loaded at position 0 should be 1
Languagefilter is enabled
Multiple Plugins have the same loading position (0)

Database:   
jDiction Database Driver is selected

Language:   
Seam to be good

Module:   
Module is enabled
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #3 on: March 19, 2013, 03:56:56 pm »

could you give me a url?

and send me a pm with superadmin account
Logged

pindrix

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #4 on: March 19, 2013, 04:49:58 pm »

Ok , thx for your help , I have send you a PM.
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #5 on: March 19, 2013, 05:37:03 pm »

Hmm, there is a problem with your jrouter, it seams any addon change the default behavior of jroute::_('x');

jdiction does all right but giving the url to jroute::_ it does something wrong.

jdiction give index.php/de/menualias to jroute::_ and should get back http://example.com/index.php/de/menualias but on your site jdiction gets http://example.com/index.php/de/menualias/en/menualias and I have no Idea why...

I suggest you uninstall all unused extensions and retry also you could make a second site and install addons until jdiction fails.
Logged

pindrix

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #6 on: March 20, 2013, 07:47:52 am »

Well

First, thx for your help. I will try to uninstall all unused extensions. But I think its in the template .
If that not works, I will do a compromise . Il make  a custom html with flags and set link to  www.mysite.com/en, ..com/de .... . It will take you on the index page  but it works .
Logged

Brueni92

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #7 on: March 23, 2013, 01:19:54 pm »

same problem here :(
It somehow doesn't replace the language path, but adds another one instead like:
/de/...--->/de/en/....
or if I click on the language that is already active:
/de/...--->/de/de/

which gives me, of course the same error as mentioned above: "article not found"
are you sure it is one of the plugins? what could it pssibly be, even if i choose th standard template beez5 which  comes with the joomla instllation it doesnt work....
could it possibly have anything to do with an joomla update, perhaps to 2.5.9 or something like this?

greetz and best regards
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #8 on: March 23, 2013, 01:32:55 pm »

Could you test version 0.9.x? Maybe its a problem in the latest version but i dont think so
Logged

Brueni92

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #9 on: March 23, 2013, 03:24:32 pm »

well i installed the version: jDiction Package 0.9
from here: http://jdiction.org/de/downloads
Logged

Brueni92

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #10 on: March 23, 2013, 05:02:09 pm »

now, i installed version 0.8.9.6 without removing version 0.9 and its working!!!
so there is something wrong with version 0.9
i hope this will help  ;)
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #11 on: March 23, 2013, 08:05:18 pm »

well thats good... I did some late changes for 0.9 maybe I fucked something up there... It possible that I need your help because on my systems there is no problem...
Logged

Brueni92

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #12 on: March 23, 2013, 09:38:50 pm »

sure, send me a mail and i wil look what i can do
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1642
    • View Profile
Re: ARTICLE NOT FOUND
« Reply #13 on: March 26, 2013, 02:43:09 pm »

Finarfin found the problem,

would you please test version 0.9.9.1 from http://forum.jdiction.org/index.php/topic,359.0.html
Logged