jDiction Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

jDiction 2.2.0 released. http://jdiction.org/downloads

Pages: 1 [2] 3

Author Topic: Nach Update auf Joomla 3.4 wechselt Menu und Content erst nach zweitem Klick  (Read 6366 times)

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile

So diese Version sollte alles abdecken...
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile

Bitte ausprobieren, gibt aber noch ein Problem bei menü parametern...
Logged

Sandra

  • Newbie
  • *
  • Posts: 13
    • View Profile

Schon besser!

Ich habe Deutsch als default Content Sprache.
Wenn die Seite auf Deutsch angezeigt wird, muss ich immer noch zweimal klicken, damit das Menu und der Artikelinhalt angezeigt werden.
Wenn die Seite auf Französisch oder Spanisch angezeigt wird, kann ich mit einem einzigen Klick zu einer anderen Sprache wechseln. Juhui!

Nebenbei: die Flaggen sind aus dem jdict-Modul verschwunden.
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile

So neuer Ansatz für einen Fix, der schaut auch besser aus.

Ja die Flaggen habe ich entfernt und verwende jetzt die Standard Joomla Flaggen.

Neue Version sollte super sein ;-) hoffentlich endlich...
Logged

Sandra

  • Newbie
  • *
  • Posts: 13
    • View Profile

Es tut mir leid, das letzte Paket hat nichts an der Situation auf meiner Website geändert. Ich dachte schon, ich hätte das falsche Paket erwischt.
Installiert ist jetzt:
    Library Version: 1.4.1-git.4ad0ffd
    Joomla Version 3.4.0 is ok.

Wie gesagt, der Wechsel zwischen den übersetzten Sprachen funktioniert inzwischen tadellos! Auch der Wechsel ins Deutsch. Das Problem bleibt hingegen unverändert beim Wechsel aus dem Deutschen (Standardsprache) in eine andere Sprache.

Ausserdem frage ich mich, warum sich bei mir die Flaggen nicht zeigen. Habe ein neues Modul angelegt, aber das hat nichts geholfen.
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile

Hmm, kann das problem auf jdiction.org nicht nachvollziehen....

das Problem mit den Flaggen ist noch a bisserl ungetestet.
Verwendest du ein eigenes template für das module?

Und kannst du mir einen link zur Seite schicken?

Logged

Sandra

  • Newbie
  • *
  • Posts: 13
    • View Profile

Es handelt sich um Protostar. Ich benutze diese Adresse als Testseite: www.schmuckliweb.ch/sandra/jo3san.

Ich habe hier nur die Basisinstallation von Joomla mit den mitgelieferten Templates, um andere Fehler auszuschliessen. Ähem, Joomgallery ist die einzige zusätzliche Extension. Ich habe die Übersetzung dafür nicht aktiviert. Aber ich könnte diese Extension auch noch entfernen. Könnte es sein, dass früher gelöschte Extensions noch "nachwirken"?

Die Seite, die aktuell in Produktion ist, findest du unter www.sandra.schmuckliweb.ch. Hier benutze ich ein von Favtheme angepasstes Template (favourite), aber die Problematik ist dieselbe. (hier habe ich noch die Version 1.4.0 von jdiction installiert).
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile

Ok, das problem tritt anscheinend nur auf wenn man kein SEF Urls verwendet, damit kannst du mal das Problem beheben.

Die Flagen funktionieren mit der angehängten Version auch wieder.
Logged

Sandra

  • Newbie
  • *
  • Posts: 13
    • View Profile

Ich habe das neuste Paket installiert (danke, die Flaggen sind wieder da!) und SEF Urls aktiviert (siehe Attachment):

Auf der Website ist alles beim alten, habe nur festgestellt, dass ich eine Fehlermeldung bekomme, wenn der Alias des Menu-Links in der Übersetzung automatisch generiert wird.

Vielen Dank für die Bemühungen!
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile

So jetzt eine version in der auch das Sprachenwechseln auf anhieb funktioniert.

Kannst du mir einen Screenshot von der Fehlermeldung schicken?
Logged

Sandra

  • Newbie
  • *
  • Posts: 13
    • View Profile

Juhee! Ende gut, alles gut!

Ein Klick reicht für alle Sprachrichtungen!

Damit ist auch die Fehlermeldung weg. Sie kam nur, wenn ich vom Deutsch aus eine andere Sprache anwählte und zudem der Seitenalias anders lautete. (auf Deutsch steht in der Adresszeile "fotoalbum" und auf Französisch "photos": Wenn ich vom deutschen Fotoalbum aus die französische Seite aufrief, kam diese Meldung (siehe Beilage). Aber eben, das Problem stand im Zusammenhang mit dem holprigen Übergang zwischen den Sprachen und hat sich nun erledigt!

Vielen herzlichen Dank! Das war wirklich flott! Ich spendier dir ein Bier (oder zwei), wenn du mal in Freiburg im Üchtland vorbeikommst!
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile

Ok, danke dann release ich mal 1.4.1 danke für deine Hilfe und wenn du willst kannst du noch ein review auf JED schreiben ;-)
Logged

Sandra

  • Newbie
  • *
  • Posts: 13
    • View Profile

Selbstverständlich, mach ich gerne!
Logged

psejoomla

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Nach Update auf Joomla 3.4 wechselt Menu und Content erst nach zweitem Klick
« Reply #28 on: September 14, 2016, 09:29:36 am »

Habe das gleiche Problem ... Joomla 3.6.2 und pkg_jdiction-2.0.0.zip installiert .... nach der Sprachauswahl kommt die ausgewählte Sprache nicht ... erst wenn ich dann F5/reload ausführe .... dann kommt die gewählte Sprache sowohl im Menü als auch im Content .... hab nach 2 Tagen google keinen Schimmer mehr was ich tun könnte
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Nach Update auf Joomla 3.4 wechselt Menu und Content erst nach zweitem Klick
« Reply #29 on: September 14, 2016, 11:50:35 am »

Das liegt an der Reihenfolge wie das Plugin geladen wird. Als erstes muss das Joomla Sprach Plugin geladen werden.
Logged
Pages: 1 [2] 3