jDiction Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

jDiction 2.2.0 released. http://jdiction.org/downloads

Author Topic: Translations don't work  (Read 10142 times)

Djole

  • Newbie
  • *
  • Posts: 2
    • View Profile
Translations don't work
« on: September 21, 2012, 12:44:31 pm »

Hy everyone,

I have installed the latest version of jDiction (0.7.9.3) on my Joomla (2.5.7), that is all components (com_jdiction,  file_jddbproxy, lib_jdiction, mod_jdlanguage, plg_finder_jdcontent, plg_jdiction) from the package, and configured them as well. Installed languages for frontend are English (en-GB) and Serbian Latin (sr-YU). But it doesn't seem to work.

When I change the language in frontend my traslations don't change menus, titles of modules, translation of pages etc.
But it does change language of system messages like authors name, dates of modifying etc.

I have tryed everything I can remember of. The only way to make it work is to create double categories, double menus, double pages, double banners for each language separately. When I go to insert translation, in the article for instance, I have only one tab (Serbian), although the article has already been made for the Serbian language. I can't insert the translation for English language.

Translations simply don't work.

Please help with your suggestions if you have any experiences in the field.

Thank you,
Djole
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1668
    • View Profile
Re: Translations don't work
« Reply #1 on: September 21, 2012, 01:00:26 pm »

Hi,

2 things first didn't tested 2.5.7 by now, second could you give me a url and maybe admin access  (per PM).

then I may could help you.

Logged
Joomla 3.9.x Release Lead
Vote at JED

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1668
    • View Profile
Re: Translations don't work
« Reply #2 on: September 21, 2012, 01:24:39 pm »

I need Superadmin rights to check database and I will jdiction.org to 2.5.7 and check if it schould work ;-)
Logged
Joomla 3.9.x Release Lead
Vote at JED

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1668
    • View Profile
Re: Translations don't work
« Reply #3 on: September 21, 2012, 02:28:40 pm »

I found the problem, if your frontend language is not the same as the backend language it could cause a problem, because you used Serbian as your default language and translated it to english. But the flag for jdiction is for Serbian translation, thats a wrong behavior of jdiction but could be solved if you use Serbian language as default language in backend.
Logged
Joomla 3.9.x Release Lead
Vote at JED

Djole

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Translations don't work
« Reply #4 on: September 21, 2012, 03:05:50 pm »

Yeah! It seems to be working. You are a genious.
Thank you a lot
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1668
    • View Profile
Re: Translations don't work
« Reply #5 on: September 21, 2012, 03:34:56 pm »

Logged
Joomla 3.9.x Release Lead
Vote at JED

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1668
    • View Profile
Re: Translations don't work
« Reply #6 on: September 21, 2012, 04:12:51 pm »

Logged
Joomla 3.9.x Release Lead
Vote at JED

spiderweb

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Translations don't work
« Reply #7 on: October 23, 2012, 10:46:53 am »

Hi, I have same problem, but with deafault czech language and english. My default settin in backend and frontend is czech, I have last version of Joomla 2.5 and jDiction 0.8. Can you help me? Web is here ppcpro.cz
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1668
    • View Profile
Re: Translations don't work
« Reply #8 on: October 28, 2012, 08:57:03 pm »

As explained in pm you didn't changed the database driver.
Logged
Joomla 3.9.x Release Lead
Vote at JED

illichenvar

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Translations don't work
« Reply #9 on: November 26, 2012, 11:15:17 pm »

hi, i have averything working, pluging, driver, translations for simply displayed articles work fine but for modules which are based on content like FreeSlider SP1 or common list with Articles in Category don't display translated articles (only translated module title is showing)

is there any solution for this?
i heave tested few translation management components before, and this one is really user friendly, but i need it to work for every module
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1668
    • View Profile
Re: Translations don't work
« Reply #10 on: November 26, 2012, 11:25:30 pm »

Modules should be copied and filtered by language parameter.

If the modules displays standard articles this should work without any modification, I don't know FreeSlider SP1
Logged
Joomla 3.9.x Release Lead
Vote at JED

illichenvar

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Translations don't work
« Reply #11 on: November 27, 2012, 10:03:38 am »

well i guess i've tried everything: (testing standard list in category, not FreeSlider SP1)
1. translate modul - only title shows up in secound language
2. make a copy of oryginal module and set apropriate language in both modules - only title shows up in secound language
3. same like 2. but left oryginal with All languages selected - only title shows up in secound language (with additional module in secound language)

...using joomla 2.5.8 and jdiction 0.8
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1668
    • View Profile
Re: Translations don't work
« Reply #12 on: November 27, 2012, 11:13:41 am »

Would you like to send me a PM with url and admin account?
Logged
Joomla 3.9.x Release Lead
Vote at JED

illichenvar

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Translations don't work
« Reply #13 on: November 28, 2012, 01:16:54 am »

now i'm working on localhost, and there's only two days for me to finish this site... then I will try to improve my work, but now:
i've noticed that if i clar all translated field (doesn't matter if it's module or article) on list there's still green bubble... and tere's another problem: before i use "tranlate" for aricle it shows up on front-end  (secound language is switched on) in module, in oryginal language... but after using "translate" it's only translated title of this module left

my question for now is: how can i erase translations? or which sql tables should i clear?

Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1668
    • View Profile
Re: Translations don't work
« Reply #14 on: November 28, 2012, 01:13:05 pm »

Clearing all fields in the translation changed nothing on the state the the article is translated, it only takes the orignal language.

You could delete all translations using sql, "TRUNCATE #__jd_store;"

Are you sure that you configured the language correctly?
http://jdiction.org/en/documentation/configuration/12-add-a-content-language

Quote
IMPORTANT: The Language Tag must match the installed language package, so if you install the jgerman translation you have to use "de-DE" as translation Tag and not "de-AT" or "de-CH".

Logged
Joomla 3.9.x Release Lead
Vote at JED