jDiction Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

jDiction 2.2.0 released. http://jdiction.org/downloads

Author Topic: Wrong URL with SEF turned on.  (Read 7766 times)

Adlorem

  • Newbie
  • *
  • Posts: 3
    • View Profile
Wrong URL with SEF turned on.
« on: September 19, 2013, 02:02:45 pm »

First of all I would like to say, you component is great ;) but:
With SEF turned on and Jdiction istalled my joomla generates wrong URLs.
Instead:
www.site.com/en/fly-drive
Generates:
www.site.com/en/en/fly-drive - which is causing 404 error.
With joomla SEF turned off everything works fine. Any solution to that?
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1684
    • View Profile
Re: Wrong URL with SEF turned on.
« Reply #1 on: September 19, 2013, 02:43:09 pm »

Whats tells the checkpage?
Logged
Joomla! 5.0 Release Manager
Vote at JED

Adlorem

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Wrong URL with SEF turned on.
« Reply #2 on: September 19, 2013, 05:13:25 pm »

Test   Result
 
Version Library Version: 0.9.9.10
Joomla Version 3.1.1 is ok.
Plugin    JDiction Plugin is enabled
Languagefilter is enabled
Multiple Plugins have the same loading position (0)
Database jDiction Database Driver is selected
Language Seam to be good
Module Module is enabled
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1684
    • View Profile
Re: Wrong URL with SEF turned on.
« Reply #3 on: September 19, 2013, 05:18:32 pm »

please check the content language permission that shouldn't be a problem but who knows, alternative can you send me superuser/pass ?
Logged
Joomla! 5.0 Release Manager
Vote at JED

Adlorem

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Wrong URL with SEF turned on.
« Reply #4 on: September 20, 2013, 11:52:49 am »

I solved this issue by restoring site from backup. Corrupted database caused this. Thank you for your help and I am sorry that I took your time.
Logged