jDiction Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

jDiction 2.2.0 released. http://jdiction.org/downloads

Author Topic: Loaging translations  (Read 16667 times)

malejnorek

  • Newbie
  • *
  • Posts: 7
    • View Profile
Loaging translations
« on: July 28, 2014, 12:22:01 pm »

Hi, i have installed latest jDiction 1.2.9.2 on Joomla 3.3.1
First problem was that i had to create table _jd_store manualy because anyone was created by instalation. When I create #__jd_store it doesn't worked so I created it with my prefix... and now when I want to switch languages page can't be found.

Code: [Select]
Test Result
 
Version
Library Version: 1.2.9.2
Joomla Version 3.3.1 is untested.
Plugin
JDiction Plugin is enabled
JDiction Plugin is loaded at position 0 should be 1
Languagefilter is enabled
Multiple Plugins have the same loading position (0)
Database
jDiction Database Driver is selected
Language
Seam to be good
Module
Module is enabled
Common mistakes
At least one menu item has the language set not to ALL.
At least one content item has the language set not to ALL.
At least one category has the language set not to ALL.

I think there is problem with some prefix because string #__ wasn't replaced to my database prefix.

some records in table:

Code: [Select]
CREATE TABLE IF NOT EXISTS `alvajoom_jd_store` (
  `idJdStore` int(11) NOT NULL AUTO_INCREMENT,
  `idLang` tinyint(4) NOT NULL COMMENT 'language id alvajoom_languages',
  `idReference` int(11) NOT NULL COMMENT 'Primary key for translation',
  `referenceTable` varchar(67) NOT NULL COMMENT 'Table of the translation',
  `referenceOption` varchar(50) NOT NULL,
  `referenceView` varchar(50) NOT NULL,
  `referenceLayout` varchar(50) NOT NULL,
  `sourcehash` varchar(32) NOT NULL,
  `value` longtext NOT NULL COMMENT 'serialized table value',
  `modified` datetime NOT NULL,
  `modified_by` int(11) NOT NULL,
  `state` tinyint(4) NOT NULL,
  PRIMARY KEY (`idJdStore`),
  UNIQUE KEY `idLang` (`idLang`,`referenceTable`,`idReference`)
) ENGINE=InnoDB  DEFAULT CHARSET=utf8 AUTO_INCREMENT=72 ;

Code: [Select]
(16, 1, 107, '#__modules', 'com_modules', 'module', 'edit', '1068d420be94ad2c3619a712fc5c1c07', '<?xml version="1.0"?>\n<jDiction><title><![CDATA[JDLANG]]></title></jDiction>\n', '2014-07-28 08:57:18', 0, 1),
...
(19, 3, 14, '#__content', 'com_content', 'article', 'edit', '47ad67712c7151688be63cb79ec259e2', '<?xml version="1.0"?>\n<jDiction><title><![CDATA[Contact]]></title><alias><![CDATA[contact]]></alias></jDiction>\n', '2014-07-28 08:58:47', 0, 1),
Logged

malejnorek

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Loaging translations
« Reply #1 on: July 28, 2014, 01:16:45 pm »

some log
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1686
    • View Profile
Re: Loaging translations
« Reply #2 on: July 28, 2014, 01:22:12 pm »

Ok, so translation should work, could you please give me the url (if its public)?
Logged
Joomla! 5.0 Release Manager
Vote at JED

malejnorek

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Loaging translations
« Reply #3 on: July 28, 2014, 01:28:38 pm »

I made it public... http://alva.cz/index.php/cs/ language switcher is in footer and i made you admin user demo/demo
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1686
    • View Profile
Re: Loaging translations
« Reply #4 on: July 28, 2014, 01:51:24 pm »

could you try to deactive the "index.php" and active .htaccess rewrite?

it shouldn't be the problem, but its a try.
Logged
Joomla! 5.0 Release Manager
Vote at JED

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1686
    • View Profile
Re: Loaging translations
« Reply #5 on: July 28, 2014, 01:52:26 pm »

And are your menu entry languages set to "ALL", also the category and articles?

because the checkpage says:

Quote
At least one menu item has the language set not to ALL.
At least one content item has the language set not to ALL.
At least one category has the language set not to ALL.
Logged
Joomla! 5.0 Release Manager
Vote at JED

malejnorek

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Loaging translations
« Reply #6 on: July 28, 2014, 02:12:50 pm »

there is no DirectoryIndex in htaccess...

and I made all articles, menues and category for one language and without effect... bud now it show error 404 :D

I think there is problem with database... supposed to look that way?
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1686
    • View Profile
Re: Loaging translations
« Reply #7 on: July 28, 2014, 02:17:29 pm »

there is no DirectoryIndex in htaccess...
I asked you to rename the htaccess.txt to .htaccess and activate "URL-Rewrite" in Joomla configuration (sorry if I was not clear enough)

and I made all articles, menues and category for one language and without effect... bud now it show error 404 :D
You need the opposite, all menus/category/articles have to be the Language "ALL" NOT "cz" or "de"

I think there is problem with database... supposed to look that way?
No database looks good.
Logged
Joomla! 5.0 Release Manager
Vote at JED

malejnorek

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Loaging translations
« Reply #8 on: July 28, 2014, 02:31:06 pm »

I see... my bad, I made it for all languages

with .htaccess and URL rewrite is site unreachable witch error 500, I don't know how to set htaccess properly

Code: [Select]
##
# @package    Joomla
# @copyright  Copyright (C) 2005 - 2014 Open Source Matters. All rights reserved.
# @license    GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.
Logged

malejnorek

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Loaging translations
« Reply #9 on: July 28, 2014, 03:18:31 pm »

Ok, URL rewrite works but when I'am trying to change language it stop on error 500

Code: [Select]
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 3 SQL=SELECT * FROM alvajoom_jd_store WHERE idLang='1' AND referenceTable='#__content' AND idReference in ()
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1686
    • View Profile
Re: Loaging translations
« Reply #10 on: July 28, 2014, 04:05:03 pm »

please send me a superuser account per PM thx.
Logged
Joomla! 5.0 Release Manager
Vote at JED

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1686
    • View Profile
Re: Loaging translations
« Reply #11 on: July 29, 2014, 10:48:24 am »

Ok, thx for access I fixed the problem and now it works.
Logged
Joomla! 5.0 Release Manager
Vote at JED

malejnorek

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Loaging translations
« Reply #12 on: July 29, 2014, 10:51:07 am »

I noticed... Awesome, Thank you very much! Can you tell me what was the problem please?  :)
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1686
    • View Profile
Re: Loaging translations
« Reply #13 on: July 29, 2014, 11:34:56 am »

I fixed the jdiction ;-) there was a problem with the query parser, that was partly fixed in 1.2.9.2 but not completely.

If you like jdiction you may write a review on JED.
Logged
Joomla! 5.0 Release Manager
Vote at JED