jDiction Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

jDiction 2.2.0 released. http://jdiction.org/downloads

Author Topic: Probleme seit Joomla! 3.4.1  (Read 2384 times)

skanag

  • Newbie
  • *
  • Posts: 11
    • View Profile
Probleme seit Joomla! 3.4.1
« on: March 30, 2015, 08:53:24 am »

Wir haben vor einiger Zeit unsere Joomla!-Version auf 3.4.1 geupdated. Seit dem haben wir massive Probleme mit der Sprachumschaltung auf der Seite: skan.ch
Beim Umschalten, schalten nur Teile des Inhalts um und viele Links generieren sich kurios und setzen sich aus mehreren Sprachen zusammen (z.B. skan.ch/de/contacts/impressum). Ausserdem lassen sich viele Unterseiten in einer Sprache gar nicht mehr aufrufen oder beim Umschalten der Sprache gibt es eine 404-Seite.
jDiciton läuft auf der neusten Version.
Kann das an jDiction liegen? Wir nutzen ansonsten keine Erweiterungen, die in die Sprachumschaltung eingreifen.
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #1 on: March 30, 2015, 12:50:54 pm »

Ja kann daran liegen, eigentlich sollte es behoben sein, aber anscheinend doch nicht.

Muss ich mir genauer ansehen
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #2 on: March 30, 2015, 01:40:39 pm »

Bitte mal das angehängt plugin installieren, dann sollte es funktionieren.
Logged

skanag

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #3 on: March 30, 2015, 01:50:15 pm »

Vielen Dank,
ich habe das Plugin installiert und es funktioniert besser, aber noch nicht einwandfrei. Fehlermeldungen kommen seltener (ein Muster erkenne ich auf die Schnelle nicht wirklich). Das Umschalten von deutsch auf englisch funktioniert. Beim Zurückschalten werden allerdings nur Teile der Seite übersetzt.
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #4 on: March 30, 2015, 02:03:41 pm »

Ich bräuchte ein paar screenshots oder zugang zur seite.
Logged

skanag

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #5 on: March 30, 2015, 02:53:39 pm »

Hier einmal zwei screenshots der auftretenden Probleme:
http://fileupload.skan.ch/download/6e9d75c1-b475-47bc-a672-cc556e018062/url_mischt_sprachen.PNG
http://fileupload.skan.ch/download/d5258c86-be26-471a-a6ee-2d4e931a873a/englisch_auf_deutscher_seite.PNG
Der zweite Screenshot entstand nach dem Umschalten der Seite auf englisch und anschliessend wieder auf deutsch.
Von deutsch nach englisch treten wie gesagt keine Probleme mehr auf.
Logged

skanag

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #6 on: April 07, 2015, 09:46:29 am »

Gibt es noch irgendetwas was wir hier versuchen können?
Die Seite ist so faktisch, besonders für nicht deutschsprachige Kunden, kaum nutzbar. Ausserdem sind wir gerade in der Umsetzung einer spanischen und französischen Seite. Ich fürchte, dass die Fehler nur noch schlimmer werden, wenn mehr als 2 Sprachebenen zusammenkommen. Ich habe versucht mögliche andere Fehlerquellen zu finden und auszuschliessen, aber so langsam gehen mir die Ideen aus. Ich kann gerne einen FTP- oder Seitenzugang einrichten, wenn das hilft.
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #7 on: April 07, 2015, 10:26:53 am »

Ja bitte ich bräuchte einen superadmin user und ftp wenn möglich, das würde es um einiges erleichtern.

Am nachmittag sollte ich dazu bekommen.
Logged

skanag

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #8 on: April 07, 2015, 11:30:48 am »

Wohin kann ich die Zugangsdaten senden?
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #9 on: April 07, 2015, 11:31:30 am »

am besten per PM
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #10 on: April 07, 2015, 09:15:22 pm »

Leider funktionieren die Zugangsdaten nicht allerdings konnte ich das Problem lokal nachstellen.
Anbei eine Version die alle Probleme lösen sollte.

Wichtig, die checkpage beachten.

Das Joomla Languagefilter Plugin muss vor dem jDiction Plugin geladen werden und danach erst alle anderen.

Bitte testen und Feedback geben, danke.
Logged

skanag

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #11 on: April 08, 2015, 09:26:09 am »

Das mit den Zugangsdaten wundert mich. Bei mir hat das problemlos funktioniert.

Ich habe das Paket installiert und alles funktioniert wieder einwandfrei.
Vielen Dank  ;D
Logged

Harald Leithner

  • Administrator
  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Probleme seit Joomla! 3.4.1
« Reply #12 on: April 08, 2015, 10:50:02 am »

Sehr gut, danke für das Info.
Logged